Migração de Dados

Como Copiar Dados Entre Sites

Este guia fornece instruções para copiar dados entre sites do Fluid.

As seções do artigo são numeradas como um guia, pois alguns dados terão dependências de outros. Você pode voltar a qualquer momento e alterar os dados, mas este método mantém quaisquer links de dados existentes, sem a necessidade de fazer isso.

Por exemplo, o arquivo 'Detalhes do Projeto' provavelmente conterá PMs atribuídos, portanto faz sentido fazer o upload do seu 'Plano de Recursos', que contém os detalhes do responsável, antes do arquivo 'Detalhes do Projeto', caso você ainda não tenha feito isso, ou precisará voltar e reatribuir os PMs posteriormente, após a criação do perfil deles no site.

Portanto, se você estiver copiando vários conjuntos de dados, é recomendável seguir a ordem listada, pulando as seções que não são necessárias.


Administração de Dados

Funções de Segurança: Você deve ser um Administrador de Dados ou Administrador de Aplicativo.

1. Catálogos

Nota: Se você estiver copiando Catálogos de um site para outro, recomendamos criar os Catálogos antes das propriedades personalizadas, pois os Catálogos são listados como um 'Tipo de Dados' ao criar uma Propriedade Personalizada que utiliza um Catálogo no Fluid.

Etapa

Instruções

Baixar do Sandbox

Localização: Console de Administração > Catálogos

Instruções:

  1. Clique no ícone 'Ferramentas'.

  2. Selecione 'Edição em Massa' no menu.

  3. Mantenha 'Incluir dados existentes' marcado.

  4. Na caixa de diálogo, você precisará selecionar o Catálogo para o qual deseja baixar as entradas do Catálogo.

    Você precisará baixar cada um deles do Sandbox e fazer o upload para a Produção para migrá-los.

  5. Clique em 'Baixar'.

Preparar o Arquivo

  • Exclua a coluna 'ID do Catálogo' - ela é gerada pelo sistema.

  • Revise e atualize quaisquer outros dados conforme necessário.

  • Para mais informações, consulte: Configurando Catálogos - na parte inferior da página há uma tabela descrevendo as colunas do arquivo.

Fazer Upload para Produção

Instruções:

Primeiro, você precisará recriar os Catálogos.

  1. Clique no botão 'Adicionar Item' para criar um Catálogo.

  2. Adicione o nome do primeiro Catálogo que você está recriando e atualize quaisquer outros detalhes para corresponder às configurações do Sandbox.

  3. Repita para cada Catálogo que você precisa migrar.


Em seguida, você precisará fazer o upload dos Valores do Catálogo usando a Edição em Massa.

  1. Clique no ícone 'Ferramentas'.

  2. Selecione 'Edição em Massa' no menu.

  3. Clique em 'Upload'.

  4. Selecione e faça o upload do arquivo que você baixou do Sandbox. Repita para cada arquivo de edição em massa de Valores do Catálogo que você baixou do Sandbox.

2. Propriedades Personalizadas

Pré-requisitos: Se você estiver copiando Catálogos de um site para outro, recomendamos criar os Catálogos antes das propriedades personalizadas, pois os Catálogos são listados como um 'Tipo de Dados' ao criar uma Propriedade Personalizada que utiliza um Catálogo no Fluid.

É importante configurar suas propriedades personalizadas antes de migrar quaisquer outros arquivos de edição em massa, pois muitos deles utilizarão propriedades personalizadas, incluindo os Detalhes do Projeto.

Etapa

Instruções

Localizar no Sandbox

Localização: Console de Administração > Propriedades Personalizadas

Replicar na Produção

Você precisará recriar manualmente as propriedades personalizadas que deseja usar no seu site de produção, com exceção das Propriedades do Projeto.

Para as propriedades de Projeto (Console de Administração > Propriedades Personalizadas > Projeto), você pode:

  1. No Sandbox, clique em Copiar do Quadro

  2. No menu, selecione Exportar para Arquivo; isso fará o download de um arquivo JSON (não uma planilha de edição em massa).

  3. Em seguida, vá para o seu site de Produção e acesse a mesma página (Console de Administração > Propriedades Personalizadas > Projeto)

  4. Clique em Copiar do Quadro

  5. No menu, clique em Importar do Arquivo

  6. Encontre o arquivo json que você baixou do Sandbox e faça o upload para a Produção

  7. Você precisará selecionar se deseja 'Substituir', 'Mesclar e Ignorar' ou 'Mesclar e Sobrescrever' - leia as descrições na caixa de diálogo e selecione a opção correta. Se você não tiver propriedades personalizadas de Projeto no Sandbox, pode escolher qualquer uma - mas certifique-se de verificar ou poderá sobrescrever dados existentes.

Nota: este recurso foi projetado para portar propriedades de quadros para projetos para uso com quadros de pipeline, mas também funciona para migração de propriedades de projeto.

Para os outros tipos de propriedades personalizadas, você pode seguir as etapas neste artigo: Configurando Propriedades Personalizadas.


3. Lista Compartilhada de Propriedades Personalizadas

É recomendável configurar suas listas compartilhadas de propriedades personalizadas antes de migrar qualquer um dos seus arquivos de edição em massa, pois muitos deles utilizarão listas compartilhadas.

Etapa

Instruções

Localizar no Sandbox

Localização: Console de Administração > Lista Compartilhada de Propriedades Personalizadas

Replicar na Produção

Você precisará recriar manualmente as propriedades personalizadas que deseja usar no seu site de produção. Você pode seguir as etapas neste artigo: Configurando Listas Compartilhadas de Propriedades Personalizadas.


4. Temas Globais

Etapa

Instruções

Baixar do Sandbox

Localização: Console de Administração > Temas Globais

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Baixar'.

  4. O arquivo de edição em massa 'Temas Globais' será baixado.

Preparar o Arquivo

  • Revise a lista de temas.

  • Remova os temas que você não deseja na Produção excluindo a linha do arquivo.

  • Nenhum outro dado precisa ser removido.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Upload'.

  4. Escolha o mesmo arquivo que você alterou e salvou.

5. Gerenciamento de Metadados

É aconselhável migrar seus metadados antes de migrar recursos, projetos e dados de projetos, pois os metadados são usados nessas áreas.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > Gerenciamento de Metadados

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar Metadados'.

  3. Clique em 'Baixar'.

Preparar o Arquivo

  • Remova os metadados que você não deseja aplicar à Produção removendo a linha do arquivo.

  • Altere os metadados que você gostaria de modificar antes de fazer o upload para a produção.

  • Não há nada específico que você precise remover; não há IDs exclusivos no arquivo de metadados.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Fazer Upload de Metadados'.

  4. Escolha o mesmo arquivo que você alterou e salvou.

Financeiro & Folhas de Ponto

Funções de Segurança: Você deve ser um Administrador Financeiro ou Administrador de Aplicativo.

6. Gerenciamento de Moedas

A moeda é usada nas tabelas de tarifas, portanto é aconselhável fazer o upload das moedas antes das tabelas de tarifas.

Etapa

Instruções

Baixar do Sandbox

Local: Administração Financeira > Gerenciamento de Moedas

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa' no menu.

  3. O arquivo de Gerenciamento de Moedas será baixado automaticamente.

Preparar o Arquivo

  • Remova todas as entradas de GUID da (coluna J) no arquivo que você baixou do Sandbox. Remover o GUID permitirá que o Fluid crie um novo registro de moeda quando o arquivo de edição em massa for carregado.

    Nota: quando você deseja alterar uma moeda que já está no sistema, o GUID identifica o registro e garante que os detalhes sejam alterados. Se você fizer o upload novamente do arquivo sem GUIDs após os registros terem sido criados, você criará registros de moeda duplicados.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa' no menu.

  3. Clique em 'Fazer Upload'.

  4. Faça o upload do arquivo de moeda que você baixou e alterou do Sandbox.

7. Tipos de Despesa

Categorias de Despesa e Tipos de Despesa também são usados nas tabelas de tarifas (aquelas da Classe 'Recurso'), portanto é aconselhável migrar as categorias e tipos de despesa antes de migrar as tabelas de tarifas.

Etapa

Instruções

Baixar do Sandbox

Local: Administração Financeira > Tipos de Despesa

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar Tipos de Despesa' no menu.

  3. O arquivo será baixado automaticamente.

Preparar o Arquivo

  • Você pode remover os IDs, mas se não o fizer, não causará um erro e o Fluid os gerará automaticamente.

  • Adicione, remova e altere quaisquer tipos que você não deseja migrar. Apenas esteja ciente de que quaisquer Categorias e Tipos de Despesa que estão sendo usados para recursos e custos não estarão mais associados quando você fizer o upload deles.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Fazer Upload de Tipos de Despesa' no menu.

  3. Clique em 'Fazer Upload'.

  4. Selecione o arquivo que você baixou do Sandbox.

8. Tabelas de Tarifas

Pré-requisitos: Gerenciamento de Moedas e Tipos de Despesa são usados pelas Tabelas de Tarifas.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > Gerenciamento de Tabelas de Tarifas

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar Tabela de Tarifas' no menu.

  3. O arquivo será baixado automaticamente.

Preparar o Arquivo

  • Remova os dados da coluna Id.

  • Remova os dados da coluna GUID.

  • Certifique-se de que você tem uma tabela de tarifas PADRÃO, pois é obrigatório ter uma tabela de tarifas padrão no site. A tabela de tarifas padrão é usada como a tabela de tarifas onde nenhuma tabela de tarifas está atribuída.

    Se você fizer o upload do arquivo e não houver uma tabela de tarifas padrão, você precisará criar uma nova tabela de tarifas e chamá-la de 'DEFAULT' e adicionar quaisquer outros detalhes.

    Nota: quando você deseja alterar uma tabela de tarifas que já está no sistema, o GUID identifica o registro e garante que os detalhes sejam alterados.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Fazer Upload de Tabela de Tarifas' no menu.

  3. Clique em 'Fazer Upload' na caixa de diálogo.

  4. Faça o upload do arquivo de tarifas que você baixou.

  5. Clique no botão 'Aplicar a Todos os Projetos' para aplicar as alterações a todas as previsões financeiras de projetos em meses abertos.


Gerenciamento de Usuários

Funções de Segurança: Você deve ser um Administrador de Usuários ou Administrador de Aplicativo.


9. Rótulos de Recursos e Nomes de Campos

  • Local: Console de Administração > Rótulos de Recursos e Nomes de Campos

  • Instruções: Localize no Sandbox e na Produção e atualize quaisquer nomes de campos que você personalizou e deseja espelhar na Produção.


10. Divisão, Departamento e Equipe

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > Divisão, Departamento e Equipe

Instruções:

  1. Clique em Ferramentas > Edição em Massa.

  2. Deixe 'Incluir dados existentes' marcado e clique em 'Baixar'.

  3. Abra o arquivo baixado.

Preparar o Arquivo

  • A menos que haja algo que você queira remover, adicionar ou alterar, você pode baixar este arquivo do Sandbox e fazer o upload diretamente para a Produção para criá-los.

  • Se algum nome de divisão, departamento ou equipe já existir na produção quando você tentar fazer o upload, essas linhas serão ignoradas durante o upload do arquivo.

  • O Fluid irá gerar todos os IDs de Divisão, IDs de Departamento e IDs de Equipe - mesmo que você não os altere no download do Sandbox, quando enviados para a Produção eles serão reatribuídos.

  • O TeamRef deve permanecer o mesmo para todas as entradas, pois eles são usados no Plano de Recursos ao criar seus usuários, recursos e marcadores. Se você tiver um Team Ref inválido, o Fluid irá gerar um.

  • Para ver a lista completa de regras de edição em massa, consulte: Fazendo upload de dados de divisão, departamento e equipe via Edição em Massa

Fazer Upload para a Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Upload'.

  4. Escolha o arquivo que você baixou do Sandbox.

  5. Aguarde a conclusão do upload.


11. Gerenciar Planos de Recursos

Isso inclui Recursos / Perfis de Usuário e Marcadores.

Pré-requisitos: Divisão, Departamento e Equipes, Rótulos de Recursos e Nomes de Campos (se rótulos e nomes de campos foram alterados)

Etapa

Instruções

Baixar do Sandbox

Local: Gerenciamento de Usuários

Administradores financeiros com a função 'Administração de Usuários' também podem encontrar essa funcionalidade na página 'Administração Financeira'.

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Gerenciar Planos de Recursos' no menu.

  3. Quando a caixa de diálogo Planos de Recursos aparecer, mantenha 'Baixar Todos os Recursos' marcado (isso irá baixar todos os perfis de usuário, incluindo aqueles que são licenciados ou colaboradores que podem fazer login, todos os recursos não licenciados usados para alocações e marcadores.

  4. Escolha se deseja baixar e migrar recursos inativos ou não, marcando a caixa de seleção relevante.

  5. Clique em 'Baixar'.

Preparar o Arquivo

  • Remova os dados nas colunas: ResourceId.

  • Atualize quaisquer funções de segurança que possam ser diferentes do Sandbox para a Produção (às vezes durante a integração, as equipes campeãs concedem níveis mais altos de acesso aos membros de sua equipe enquanto exploram o produto, mas podem não querer fornecer esse nível na produção).

  • Certifique-se de que quaisquer colunas de propriedades personalizadas (começando com um sublinhado '_') foram criadas na produção ou, se você não estiver replicando na produção, remova a coluna do arquivo).

  • Para mais orientações sobre o Upload em Massa do Plano de Recursos, consulte: Upload em Massa do Plano de Recursos

Fazer Upload para a Produção

Instruções:

  1. Quando a caixa de diálogo Planos de Recursos aparecer, clique em 'Upload'.

  2. Selecione o arquivo que você baixou do Sandbox e alterou e faça o upload do arquivo.

Configurações do Projeto

Funções de Segurança: Você deve ser um Administrador de Projeto ou Administrador de Aplicativo.


12. Rótulos do Projeto e Nomes de Campos

  • Local: Console de Administração > (Configurações do Projeto) Rótulos do Projeto e Nomes de Campos

  • Instruções: Localize no Sandbox e na Produção e atualize quaisquer nomes de campos que você personalizou e deseja espelhar na Produção.

  • Observe que nesta seção, você não apenas atualiza os rótulos do projeto, mas os controles para suas configurações de Relatório de Status, configurações de Impactos do Projeto e a página padrão do Painel global (Página de Lista de Observação Padrão) também são definidos aqui, portanto, verifique-os.

  • Você pode ler mais aqui: Rótulos do Projeto e Nomes de Campos.

13. Configurar Recursos do Projeto

  • Local: Console de Administração > (Configurações do Projeto) Configurar Recursos do Projeto

  • Instruções: Alinhe as configurações do Sandbox para a Produção e clique em 'Salvar'.

14. Modelos de Projeto

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > (Configurações do Projeto) Modelos de Projeto

Instruções:

Você precisará fazer isso para cada modelo de projeto que deseja migrar do Sandbox para a produção.

  1. Clique no nome do modelo ou no ícone de lápis 'Editar' para abrir a caixa de diálogo de detalhes do modelo.

  2. Baixe os arquivos do modelo.

Preparar o Arquivo

Fazer Upload para a Produção

Instruções:

Você precisará fazer isso para cada modelo de projeto que deseja migrar do Sandbox para a produção.

  1. Clique no botão 'Criar'.

  2. Adicione os detalhes do modelo na caixa de diálogo, correspondendo-os ao modelo que você está copiando do Sandbox.

  3. Clique em 'Salvar'.

  4. A caixa de diálogo será fechada.

  5. Encontre o novo modelo na lista e clique no nome ou no ícone de lápis 'Editar'.

  6. Faça o upload dos arquivos do modelo que você baixou do Sandbox nas áreas relevantes.

  7. Clique em 'Salvar'.

15. Impacto, Probabilidade e Classificação de Risco

  • Console de Administração > (Configurações do Projeto) Impacto, Probabilidade e Classificação de Risco

16. Metodologias, Fases e Portões de Estágio

Os projetos usarão esses elementos, portanto é recomendável migrar as metodologias, fases e portões de estágio antes de fazer upload dos projetos, caso você queira que o projeto mantenha os vínculos com eles.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > (Configurações do Projeto) Metodologias, Fases e Portões de Estágio

Nota: se os Portões de Estágio não estiverem ativados, o link será exibido como 'Metodologias, Fases e Tarefas'.

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Baixar'.

Preparar o Arquivo

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Edição em Massa'.

  3. Clique em 'Upload'.

  4. Escolha o arquivo que você baixou da produção e faça o upload.

  5. Você precisará criar manualmente os Portões de Fase e Portões de Estágio em produção, pois o arquivo de edição em massa atualmente suporta apenas Metodologias, Fases e Tarefas de Fase.

  6. Clique no botão 'Aplicar a Todos os Projetos' para aplicar os novos portões aos projetos existentes.


17. Tipos de Projeto

Os projetos usarão esses elementos, portanto é recomendável migrar os Tipos de Projeto antes de fazer upload dos projetos, caso você queira que o projeto mantenha os vínculos com eles.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > (Configurações do Projeto) Tipos de Projeto

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar MetaDados'.

  3. O arquivo será baixado automaticamente.

Preparar o Arquivo

  • Você não precisa atualizar o arquivo, a menos que deseje adicionar ou alterar os tipos de projeto. Os IDs serão gerados automaticamente independentemente de você deixá-los ou removê-los e deixá-los em branco no arquivo.

    Apenas esteja ciente de que, se você alterar algum ao qual seus projetos estejam vinculados, eles precisarão ser atualizados no arquivo de Detalhes do Projeto.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Fazer Upload de MetaDados'.

  3. Clique em 'Upload'.

  4. Escolha o arquivo que você baixou da produção e faça o upload.


18. Portfólios e SubPortfólios

Os projetos usarão esses elementos, portanto é recomendável migrar os portfólios e subportfólios antes de fazer upload dos projetos, caso você queira que o projeto mantenha os vínculos com eles.

Pré-requisitos: Se você tiver administradores, aprovadores ou visualizadores de portfólio ou subportfólio atribuídos, faz sentido ter importado seus planos de recursos (que incluem seus perfis de recursos).

Se não tiver feito isso, você pode voltar e reatribuir os administradores, aprovadores e visualizadores posteriormente, quando tiver criado os usuários no sistema.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > (Configurações do Projeto) Portfólio e SubPortfólios

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar Portfólio e SubPortfólio'.

  3. O arquivo será baixado automaticamente.

Preparar o Arquivo

  • Você não precisa atualizar o arquivo, a menos que deseje adicionar ou alterar os portfólios.

    Apenas esteja ciente de que, se você alterar algum ao qual seus projetos estejam vinculados, eles precisarão ser atualizados no arquivo de Detalhes do Projeto.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Fazer Upload de Portfólio e SubPortfólio'.

  3. Clique em 'Upload'.

  4. Escolha o arquivo que você baixou da produção e faça o upload.


19. Camadas e Direcionadores de Negócio

Os projetos usarão esses elementos, portanto é recomendável migrar as Camadas e Direcionadores de Negócio antes de fazer upload dos projetos, caso você queira que o projeto mantenha os vínculos com eles.

Etapa

Instruções

Baixar do Sandbox

Local: Console de Administração > (Configurações do Projeto) Camadas e Direcionadores de Negócio

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Exportar Camada e Direcionador de Negócio'.

  3. O arquivo será baixado automaticamente.

Preparar o Arquivo

  • Você não precisa atualizar o arquivo, a menos que deseje adicionar ou alterar as camadas e direcionadores de negócio.

    Apenas esteja ciente de que, se você alterar algum ao qual seus projetos estejam vinculados, eles precisarão ser atualizados no arquivo de Detalhes do Projeto.

Fazer Upload para Produção

Instruções:

  1. Clique no menu 'Ferramentas'.

  2. Selecione 'Fazer Upload de Camada e Direcionador de Negócio'.

  3. Clique em 'Upload'.

  4. Escolha o arquivo que você baixou da produção e faça o upload.

Projetos

Funções de Segurança: Apenas usuários com funções de Administrador Financeiro e Administrador de Dados em suas contas podem baixar e carregar detalhes do projeto. Usuários com apenas a função de Administrador Financeiro podem apenas baixar o arquivo de detalhes do projeto, mas não podem carregá-lo.

20. Detalhes do Projeto

Pré-requisitos: Planos de Recursos, Catálogos, Propriedades Personalizadas (Projeto), Listas Compartilhadas de Propriedades Personalizadas, Metadados, Temas Globais, Rótulos de Projeto e Nomes de Campos, Configurar Recursos do Projeto, Metodologias, Fases e Portões de Estágio, Tipos de Projeto, Portfólio e SubPortfólios, Nível e Drivers de Negócio.

Etapa

Instruções

Baixar do Sandbox

Local: Administração de Dados > Detalhes do Projeto (Download)

Instruções:
Clique no botão 'Download' para os 'Detalhes do Projeto'; o arquivo será baixado automaticamente.

Ou

Local: Projetos (Navegação Superior) > Ferramentas > Edição em Massa

Instruções:

  1. Você pode filtrar a lista de observação dos painéis para incluir apenas o projeto para o qual deseja baixar os dados.

    Por exemplo, se você quiser migrar apenas projetos 'Ativos', aplique o filtro de Status 'Ativo' antes de baixar o arquivo de edição em massa 'Detalhes do Projeto'.

  2. 'Ferramentas' > 'Edição em Massa'.

  3. Selecione Detalhes do Projeto no lado esquerdo do diálogo de Edição em Massa.

  4. Se você quiser baixar os dados existentes dos projetos para o arquivo, defina o sinalizador como Sim. Para extrair um arquivo de upload em branco, defina como Não.

  5. Clique em Download.

Preparar o Arquivo

  • Remova quaisquer linhas de projetos que você não deseja migrar do arquivo de edição em massa.

  • Remova todos os dados das colunas que contêm IDs de projeto e números de referência: ProjectID, ProjectGuid, Immediate Parent Id, Top Parent Project Id, Program Id.

  • Certifique-se de que seus campos de propriedades personalizadas (aqueles que começam com um sublinhado '_', estejam disponíveis em produção).

  • Você pode deixar os dados de Immediate Parent, Immediate Parent Ref, Top Parent Project, Top Parent Project Ref, Program, Program Ref, ReportingProgram e Reporting Program Ref no arquivo para revinculação dos seus projetos e criação das hierarquias de projetos.

  • Você pode deixar a data de ProjectRef no arquivo. As Tarefas de Cronograma fazem referência a elas para vinculá-las ao projeto.

  • Para mais orientações, consulte: Detalhes do Projeto: Edição em Massa e Upload de Detalhes do Projeto

Carregar para Produção

Local: Administração de Dados > Detalhes do Projeto (Upload)

Instruções:

  1. Clique no botão 'Upload' para os 'Detalhes do Projeto'.

  2. Selecione 'Carregar Dados' e procure o arquivo que você baixou e alterou do Sandbox.

OU

Local: Projetos (Navegação Superior) > Ferramentas > Edição em Massa

Instruções:

  1. 'Ferramentas' > 'Edição em Massa'.

  2. Selecione 'Detalhes do Projeto' no lado esquerdo do diálogo de Edição em Massa.

  3. Se você quiser baixar os dados existentes do(s) projeto(s) para o arquivo, defina o sinalizador como Sim. Para extrair um arquivo de upload em branco, defina como Não.

  4. Clique em Upload.

  5. Selecione o arquivo que você baixou e alterou do Sandbox.

21. Cronogramas

Pré-requisitos: Metadados, projetos (Detalhes do Projeto) e Planos de Recursos para vincular quaisquer responsáveis por tarefas.

Arquivo: Tarefas de Cronograma

Etapa

Instruções

Baixar do Sandbox

Local: Projetos (Navegação Superior) > Ferramentas > Edição em Massa

Instruções:

  1. Você pode filtrar a lista de observação dos painéis para incluir apenas as tarefas do projeto para as quais deseja baixar os dados.

    Por exemplo, se você quiser migrar apenas projetos 'Ativos', aplique o filtro de Status 'Ativo' antes de baixar o arquivo de edição em massa 'Tarefas de Cronograma' para obter uma lista de tarefas apenas para projetos ativos.

  2. 'Ferramentas' > 'Edição em Massa'.

  3. Selecione 'Tarefas de Cronograma' no lado esquerdo do diálogo de Edição em Massa.

  4. Marque 'Incluir dados existentes' para baixar dados existentes. Marque 'Incluir subprojetos' para incluir subprojetos.

  5. Clique em Download.

Preparar o Arquivo

  • Remova quaisquer dados nas colunas ProjectId, Id e Guid.

  • Importante: Lembre-se de que, ao carregar uma linha de tarefa de cronograma em um arquivo de edição em massa que não possui GUID, o Fluid criará uma nova tarefa com esses detalhes. Se você já adicionou alguma das tarefas de cronograma no Fluid, precisará removê-las do arquivo para não criar tarefas duplicadas nos projetos.

  • Para mais informações, consulte: Edição em Massa do Cronograma do Projeto

Carregar para Produção

Instruções:

  1. 'Ferramentas' > 'Edição em Massa'.

  2. Selecione 'Tarefas de Cronograma' no lado esquerdo do diálogo de Edição em Massa.

  3. Clique em Upload.

  4. Selecione o arquivo que você baixou e alterou do Sandbox.

23. Impactos do Projeto

Pré-requisitos: Rótulos de Projeto e Nomes de Campos (Impactos do Projeto), projetos (Detalhes do Projeto) e Planos de Recursos para manutenção dos responsáveis pelos impactos.

Etapa

Instruções

Baixar do Sandbox

Local: Projetos (Navegação Superior) > Ferramentas > Edição em Massa

Instruções:

  1. Você pode filtrar a lista de observação dos painéis para incluir apenas os impactos do projeto para os quais deseja baixar os dados.

    Por exemplo, se você quiser migrar apenas projetos 'Ativos', aplique o filtro de Status 'Ativo' antes de baixar o arquivo de edição em massa 'Impactos' para obter uma lista de impactos apenas para projetos ativos.

  2. 'Ferramentas' > 'Edição em Massa'.

  3. Selecione 'Impactos do Projeto' no lado esquerdo do diálogo de Edição em Massa.

  4. Marque 'Incluir dados existentes' para baixar dados existentes.

  5. Clique em Download.

Preparar o Arquivo

Carregar para Produção

Instruções:

  1. 'Ferramentas' > 'Edição em Massa'.

  2. Selecione 'Impactos do Projeto' no lado esquerdo do diálogo de Edição em Massa.

  3. Clique em Upload.

  4. Selecione o arquivo que você baixou e alterou do Sandbox.

24. Relatórios de Status

Pré-requisitos: Propriedades Personalizadas, Metadados (RAGs e RAGs de Componentes), projetos (Detalhes do Projeto), Planos de Recursos, pois os status do projeto utilizam responsáveis para estabelecer proprietários, e Impactos, para manter quaisquer impactos vinculados.

Estas instruções orientam você sobre como importar o relatório de status de projeto mais recente para cada um dos projetos. Há instruções para carregar relatórios de status históricos projeto a projeto abaixo da primeira tabela.

Etapa

Instruções

Baixar do Sandbox

Local: Painéis de Projetos (Clique no botão 'Projects' na barra de navegação superior.

Instruções:

  1. Antes de baixar o arquivo de edição em massa, você pode adicionar filtros ao painel para selecionar apenas os projetos que deseja migrar.

    Por exemplo, se você deseja migrar apenas projetos ativos, pode aplicar o filtro de Status 'Active' e baixar os detalhes apenas desses projetos.

  2. Clique em Tools > Bulk Edit.

  3. Selecione 'Project Status' na lista do lado esquerdo.

  4. Deixe 'Include Existing Data' marcado.

  5. Clique em 'Download'.

Preparar o Arquivo

  • Remova todos os dados das colunas ProjectId.

  • Remova todos os dados de outras colunas que usam um ID, como: Resource Issue/Risk Id, Scope Issue/Risk Id e as colunas Timeline Issue/Risk Id, pois elas terão IDs diferentes em Produção.

  • Remova as linhas de projetos para os quais você não deseja fazer upload do status em Produção.

  • Para mais informações, consulte: Project Status: Bulk Edit

Fazer Upload para Produção

Instruções:

  1. Clique em Tools > Bulk Edit.

  2. Selecione 'Project Status' na lista do lado esquerdo.

  3. Clique em 'Upload'.

  4. Faça upload do arquivo que você baixou do Sandbox e atualizou.

Para adicionar os relatórios históricos de status do projeto a um projeto individual:

Etapa

Instruções

Baixar do Sandbox

Local: Área de Trabalho do Projeto

Instruções:

  1. Clique em Tools > Bulk Edit.

  2. Selecione 'Project Status' na lista do lado esquerdo.

  3. Deixe 'Include Existing Data' marcado.

  4. Clique em 'Download'.

Preparar o Arquivo

  • Você não precisa atualizar o arquivo, mas verifique se adicionou quaisquer propriedades personalizadas usadas pelo relatório de status em Produção, ou se não estiver migrando essas propriedades, remova do arquivo de edição em massa as colunas de propriedades personalizadas que não existem em Produção.

  • Para mais informações, consulte: Project Status: Bulk Edit

Fazer Upload para Produção

Instruções:

  1. Encontre o projeto correspondente em Produção ao qual deseja aplicar os relatórios de status.

  2. Clique em Tools > Bulk Edit.

  3. Selecione 'Project Status'.

  4. Clique em 'Upload'.

  5. Faça upload do arquivo que você baixou do Sandbox'.

Previsões de Recursos

25. Previsões de Recursos

Pré-requisitos: Metadata Management, Rate Cards, Resource Labels & Field Names, Resource Plans, Project Details.

Arquivo: Resource Forecasts

Etapa

Instruções

Baixar do Sandbox

Local: Painéis de Projetos (Clique no botão 'Projects' na barra de navegação superior.

Instruções:

  1. Antes de baixar o arquivo de edição em massa, você pode adicionar filtros ao painel para selecionar apenas os projetos que deseja migrar.

    Por exemplo, se você deseja migrar apenas projetos ativos, pode aplicar o filtro de Status 'Active' e baixar os detalhes apenas desses projetos.

  2. Clique em Tools > Bulk Edit.

  3. Selecione 'Resource Forecast' na lista do lado esquerdo.

  4. Mantenha 'Include existing data' marcado.

  5. Escolha o intervalo de datas que você está baixando.

  6. Clique em 'Download'.

Preparar o Arquivo

Fazer Upload para Produção

Instruções:

  1. Clique em Tools > Bulk Edit.

  2. Selecione 'Resource Forecast' na lista do lado esquerdo.

  3. Clique em 'Upload'.

  4. Selecione e faça upload do arquivo que você baixou e alterou do Sandbox.


Financeiro de Projetos

Funções de Segurança: Você deve ser um Administrador Financeiro ou Administrador de Aplicação.

26. Previsões de Linha de Base

Pré-requisitos: MetaData Management, Project Details, Currencies, Expense Categories and Types, Resource Plans.

Arquivo: Baseline Forecast

Etapa

Instruções

Baixar do Sandbox

Local: Painéis de Projetos (Clique no botão 'Projects' na barra de navegação superior.

Instruções:

  1. Antes de baixar o arquivo de edição em massa, você pode adicionar filtros ao painel para selecionar apenas os projetos que deseja migrar.

    Por exemplo, se você deseja migrar apenas projetos ativos, pode aplicar o filtro de Status 'Active' e baixar os detalhes apenas desses projetos.

  2. Clique em Tools > Bulk Edit.

  3. Selecione 'Baseline Forecast' na lista do lado esquerdo.

  4. Escolha o intervalo de datas que você está baixando.

  5. Escolha 'Download Baseline Forecast' ou 'Download Full Year Forecast' dependendo do que você precisa.

  6. Clique em 'Download'.

Preparar o Arquivo

  • Remova os dados da coluna ProjectId.

Fazer Upload para Produção

Instruções:

  1. Clique em Tools > Bulk Edit.

  2. Selecione 'Baseline Forecast' na lista do lado esquerdo.

  3. Clique em 'Upload'.

  4. Selecione e faça upload do arquivo que você baixou e alterou do Sandbox.


27. Benefícios do Projeto

Pré-requisitos: MetaData Management, Project Details, Currencies, Expense Categories and Types, Resource Plans.

Arquivos: Benefícios do Projeto (Fluid Benefits-qualitative, Fluid Benefits-quantitative, Fluid Benefits-quantitativeNonResourcing)

Etapa

Instruções

Baixar do Sandbox

Localização: Painéis de Projetos (Clique no botão 'Projetos' na barra de navegação superior.)

Instruções:

  1. Antes de baixar o arquivo de edição em massa, você pode adicionar filtros ao painel para selecionar apenas os projetos que deseja migrar.

    Por exemplo, se você deseja migrar apenas projetos ativos, pode aplicar o filtro de Status 'Ativo' e baixar os detalhes apenas desses projetos.

  2. Clique em Ferramentas > Edição em Massa.

  3. Selecione 'Benefícios do Projeto' na lista do lado esquerdo.

  4. Você tem três opções na forma de caixas de seleção: Baixar Benefícios Qualitativos, Baixar Benefícios Quantitativos de Recursos e Baixar Benefícios Quantitativos Sem Recursos. Se você estiver migrando todos eles, clique em cada opção e baixe o arquivo individualmente.

  5. Escolha se deseja 'Incluir benefícios encerrados'.

  6. Clique em 'Baixar'.

Preparar o Arquivo

  • Remova os dados da coluna ProjectId.

  • Remova os dados da coluna GUID.

    Importante: Lembre-se de que, ao carregar uma linha em um arquivo de edição em massa que não possui GUID, o Fluid criará um novo benefício de projeto com esses detalhes. Se você já adicionou algum dos benefícios do projeto no Fluid, remova-os do arquivo para não criar benefícios de projeto duplicados.

  • Para mais informações, consulte: Benefícios do Projeto: Edição em Massa

Carregar para Produção

Instruções:

  1. Clique em Ferramentas > Edição em Massa.

  2. Selecione 'Benefícios do Projeto' na lista do lado esquerdo.

  3. Clique em 'Carregar'.

  4. Selecione e carregue o arquivo que você baixou e alterou do Sandbox. Faça isso para cada um dos arquivos que você baixou.

Painéis de Projetos e Modelos de Relatórios



Solução de Problemas

Arquivo em Massa: Linhas Ignoradas ou Dados Não Carregados

Quando seu arquivo é carregado, o diálogo listará quaisquer problemas encontrados. Ele exibirá o número da linha na planilha e o motivo pelo qual a linha foi ignorada. Você pode usar isso para diagnosticar quaisquer problemas com seus dados.


Para corrigir quaisquer problemas com os dados de linhas ignoradas, na maioria dos casos, você pode reabrir o arquivo que carregou, fazer as atualizações necessárias, salvar e recarregar o arquivo.

Nota Importante: Se as linhas do arquivo usarem GUIDs, lembre-se de não recarregar o arquivo com as linhas que foram carregadas com sucesso, ou você poderá criar duplicatas desses itens. O arquivo 'Tarefas de Cronograma' é um exemplo disso.

Nos casos em que algumas linhas não foram carregadas e as linhas usam GUIDs, você deve remover do arquivo todas as linhas que você confirmou que foram carregadas, para não criar esses itens novamente.

Was this article helpful?