Migración de Datos

Cómo copiar datos entre sitios

Esta guía proporciona instrucciones para copiar datos entre sitios de Fluid.

Las secciones del artículo están numeradas a modo de guía, ya que algunos datos tendrán dependencias con otros. Puede volver atrás en cualquier momento y modificar los datos, pero este método mantiene los vínculos de datos existentes, sin necesidad de hacerlo.

Por ejemplo, es probable que el archivo de 'Detalles del proyecto' contenga los PM asignados, por lo que tiene sentido cargar su 'Plan de recursos', que contiene los detalles de los asignados, antes que su archivo de 'Detalles del proyecto', si aún no lo ha hecho, o tendrá que volver atrás y reasignar los PM más adelante, una vez que se haya creado su perfil en el sitio.

Por lo tanto, si va a copiar varios conjuntos de datos, se recomienda seguir el orden indicado, omitiendo las secciones que no necesite.


Administración de Datos

Roles de seguridad: Debe ser Administrador de datos o Administrador de la aplicación.

1. Catalogs

Nota: Si va a copiar Catalogs de un sitio a otro, le recomendamos crear los Catalogs antes que las propiedades personalizadas, ya que los Catalogs aparecen listados como un 'Tipo de dato' al crear una Propiedad personalizada que utilice un Catalog en Fluid.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > Catalogs

Instrucciones:

  1. Haga clic en el ícono 'Herramientas'.

  2. Seleccione 'Edición Masiva' en el menú.

  3. Mantenga marcada la opción 'Incluir datos existentes'.

  4. En el cuadro de diálogo, deberá seleccionar el Catalog del que desea descargar las entradas del catálogo.

    Deberá descargar cada uno de estos desde Entorno de Pruebas y cargarlos en Production para migrarlos.

  5. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine la columna 'Catalog ID'; esta se genera automáticamente por el sistema.

  • Revise y actualice cualquier otro dato según sea necesario.

  • Para obtener más información, consulte: Setting up Catalogs: al final de la página hay una tabla que describe las columnas del archivo.

Cargar en Production

Instrucciones:

Primero deberá volver a crear los Catalogs.

  1. Haga clic en el botón 'Add Item' para crear un Catalog.

  2. Agregue el nombre del primer Catalog que está recreando y actualice el resto de los detalles para que coincidan con la configuración de Entorno de Pruebas.

  3. Repita el proceso para cada Catalog que necesite migrar.


A continuación, deberá cargar los valores del Catalog mediante Edición Masiva.

  1. Haga clic en el ícono 'Herramientas'.

  2. Seleccione 'Edición Masiva' en el menú.

  3. Haga clic en 'Subir'.

  4. Seleccione y cargue el archivo que descargó de Entorno de Pruebas. Repita el proceso para cada uno de los archivos de edición masiva de valores del Catalog que descargó de Entorno de Pruebas.

2. Propiedades Personalizadas

Requisitos previos: Si va a copiar Catalogs de un sitio a otro, le recomendamos crear los Catalogs antes que las propiedades personalizadas, ya que los Catalogs aparecen listados como un 'Tipo de dato' al crear una Propiedad personalizada que utilice un Catalog en Fluid.

Es importante configurar sus propiedades personalizadas antes de migrar cualquier otro archivo de edición masiva, ya que muchos de estos utilizarán propiedades personalizadas, incluidos los Detalles del proyecto.

Paso

Instrucciones

Localizar en Entorno de Pruebas

Ubicación: Consola de Administración > Propiedades Personalizadas

Replicar en Production

Deberá volver a crear manualmente las propiedades personalizadas que desea utilizar en su sitio de producción, con excepción de las Propiedades de proyecto.

Para las propiedades de Proyecto (Consola de Administración > Propiedades Personalizadas > Proyecto), puede:

  1. Desde Entorno de Pruebas, haga clic en Copy From Board

  2. En el menú, seleccione Export to File; esto descargará un archivo JSON (no una hoja de cálculo de edición masiva).

  3. Luego vaya a su sitio de Production y ubique la misma página (Consola de Administración > Propiedades Personalizadas > Proyecto)

  4. Haga clic en Copy From Board

  5. En el menú, haga clic en Import from File

  6. Busque el archivo json que descargó de Entorno de Pruebas y cárguelo en Production

  7. Deberá seleccionar si desea 'Replace', 'Merge & Skip' o 'Merge & Overwrite'; lea las descripciones en el cuadro de diálogo y seleccione la correcta. Si no tiene propiedades personalizadas de Proyecto en Entorno de Pruebas, puede elegir cualquiera, pero asegúrese de verificar, o podría sobrescribir datos existentes.

Nota: esta función está diseñada para trasladar propiedades de tableros a proyectos para su uso con tableros de canalización, pero también funciona para la migración de propiedades de proyecto.

Para los demás tipos de propiedades personalizadas, puede seguir los pasos de este artículo: Setting Up Custom Properties.


3. Lista compartida de propiedades personalizadas

Se recomienda configurar las listas compartidas de propiedades personalizadas antes de migrar cualquiera de sus archivos de edición masiva, ya que muchos de estos utilizarán listas compartidas.

Paso

Instrucciones

Localizar en Entorno de Pruebas

Ubicación: Consola de Administración > Lista compartida de propiedades personalizadas

Replicar en Production

Deberá volver a crear manualmente las propiedades personalizadas que desea utilizar en su sitio de producción. Puede seguir los pasos de este artículo: Setting Up Custom Property Shared Lists.


4. Temas Globales

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > Temas Globales

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Descargar'.

  4. Se descargará el archivo de edición masiva de 'Temas Globales'.

Preparar el archivo

  • Revise la lista de temas.

  • Elimine cualquier tema que no desee en Production borrando la fila del archivo.

  • No es necesario eliminar ningún otro dato.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Subir'.

  4. Elija el mismo archivo que modificó y guardó.

5. Gestión de Metadatos

Se recomienda migrar sus metadatos antes de migrar los recursos, proyectos y datos de proyecto, ya que los metadatos se utilizan en estas áreas.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > Gestión de Metadatos

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export Metadata'.

  3. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine cualquier metadato que no desee aplicar en Production borrando la fila del archivo.

  • Modifique cualquier metadato que desee cambiar antes de cargarlo en producción.

  • No hay nada específico que deba eliminar; no hay identificadores únicos en el archivo de metadatos.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Upload Metadata'.

  4. Elija el mismo archivo que modificó y guardó.

Finanzas y Hojas de Horas

Roles de seguridad: Debe ser Administrador financiero o Administrador de la aplicación.

6. Gestión de moneda

La moneda se utiliza en las tablas de tarifas, por lo que es recomendable cargar las monedas antes que las tablas de tarifas.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Administración Financiera > Gestión de moneda

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva' en el menú.

  3. El archivo de Gestión de moneda se descargará automáticamente.

Preparar el archivo

  • Elimine todas las entradas de GUID de la columna J en el archivo que descargó de Entorno de Pruebas. Al eliminar el GUID, Fluid creará un nuevo registro de moneda cuando se cargue el archivo de edición masiva.

    Nota: cuando desee modificar una moneda que ya está en el sistema, el GUID identifica el registro y garantiza que los detalles se modifiquen. Si vuelve a cargar el archivo sin GUIDs después de que se hayan creado los registros, creará registros de moneda duplicados.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva' en el menú.

  3. Haga clic en 'Subir'.

  4. Cargue el archivo de monedas que descargó y modificó de Entorno de Pruebas.

7. Tipos de gastos

Las Categorías de gastos y los Tipos de gastos también se utilizan en las tablas de tarifas (las de clase 'Recurso'), por lo que se recomienda migrar las categorías y tipos de gastos antes de migrar las tablas de tarifas.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Administración Financiera > Tipos de gastos

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export Expense Types' en el menú.

  3. El archivo se descargará automáticamente.

Preparar el archivo

  • Puede eliminar los ID, pero si no lo hace, no provocará un error, ya que Fluid los generará automáticamente de todos modos.

  • Agregue, elimine y modifique los tipos que no desee migrar. Tenga en cuenta que las Categorías de gastos y los Tipos que se estén usando para recursos y costos dejarán de estar asociados cuando los cargue.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Upload Expense Types' en el menú.

  3. Haga clic en 'Subir'.

  4. Seleccione el archivo que descargó de Entorno de Pruebas.

8. Rate Cards

Requisitos previos: La Gestión de moneda y los Tipos de gastos son utilizados por las Rate Cards.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > Gestión de Tablas de Tarifas

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export Rate Card' en el menú.

  3. El archivo se descargará automáticamente.

Preparar el archivo

  • Elimine los datos de la columna Id.

  • Elimine los datos de la columna GUID.

  • Asegúrese de contar con una rate card DEFAULT, ya que es obligatorio tener una rate card predeterminada en el sitio. La rate card predeterminada se utiliza cuando no hay ninguna rate card asignada.

    Si carga el archivo y no hay una rate card predeterminada, deberá crear una nueva rate card y llamarla 'DEFAULT', además de agregar los demás detalles.

    Nota: cuando desee modificar una rate card que ya está en el sistema, el GUID identifica el registro y garantiza que los detalles se modifiquen.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Upload Rate Card' en el menú.

  3. Haga clic en 'Upload' en el cuadro de diálogo.

  4. Cargue el archivo de tarifas que descargó.

  5. Haga clic en el botón 'Apply to All Projects' para aplicar los cambios a todas las previsiones financieras de proyecto en los meses abiertos.


Gestión de usuarios

Roles de seguridad: Debe ser Administrador de usuarios o Administrador de la aplicación.


9. Etiquetas de recursos y nombres de campos

  • Ubicación: Consola de Administración > Etiquetas de recursos y nombres de campos

  • Instrucciones: Localice en Entorno de Pruebas y en Production, y actualice los nombres de campo que haya personalizado y que desee reflejar en Production.


10. Division, Department and Team

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > Division, Department and Team

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Deje marcada la opción 'Incluir datos existentes' y haga clic en 'Descargar'.

  3. Abra el archivo descargado.

Preparar el archivo

  • A menos que haya algo que desee eliminar, agregar o cambiar, puede descargar este archivo de Entorno de Pruebas y volver a cargarlo directamente en Production para crearlos.

  • Si algún nombre de división, departamento o equipo ya existe en producción al intentar cargarlo, esas filas se omitirán durante la carga del archivo.

  • Fluid generará los ID de División, ID de Departamento e ID de Equipo; incluso si no los modifica en la descarga de Entorno de Pruebas, se reasignarán al cargarlos en Production.

  • El TeamRef debe permanecer igual para todas las entradas, ya que estos se utilizan en el Plan de recursos al crear sus usuarios, recursos y marcadores de posición. Si tiene un Team Ref no válido, Fluid generará uno.

  • Para ver la lista completa de reglas de edición masiva, consulte: Uploading division, department and team data via Bulk Edit

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Subir'.

  4. Elija el archivo que descargó de Entorno de Pruebas.

  5. Espere a que finalice la carga.


11. Gestionar planes de recursos

Esto incluye Recursos / Perfiles de usuario y Marcadores de posición.

Requisitos previos: Division, Department and Team, Etiquetas de recursos y nombres de campos (si se han cambiado las etiquetas y los nombres de campo)

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Gestión de usuarios

Los administradores financieros con un rol de 'User Administration' también pueden encontrar esta funcionalidad en la página de 'Financial Administration'.

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Manage Resource Plans' en el menú.

  3. Cuando aparezca el cuadro de diálogo Resource Plans, mantenga marcada la opción 'Download All Resources' (esto descargará todos los perfiles de usuario, incluidos los con licencia o colaboradores que pueden iniciar sesión, todos los recursos sin licencia utilizados para asignaciones y los marcadores de posición.

  4. Elija si desea descargar y migrar los recursos inactivos marcando la casilla correspondiente.

  5. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine los datos de la columna: ResourceId.

  • Actualice los roles de seguridad que puedan ser diferentes entre Entorno de Pruebas y Production (a veces, durante la incorporación, los equipos champion otorgan niveles de acceso más altos a los miembros de su equipo mientras exploran el producto, pero es posible que no deseen proporcionar este nivel en producción).

  • Asegúrese de que las columnas de propiedades personalizadas (que comienzan con un guion bajo '_') se hayan creado en producción, o si no las está replicando en producción, asegúrese de eliminar la columna del archivo).

  • Para obtener más orientación sobre la Carga masiva del Plan de recursos, consulte: Resource Plan Bulk Upload

Cargar en Production

Instrucciones:

  1. Cuando aparezca el cuadro de diálogo Resource Plans, haga clic en 'Subir'.

  2. Seleccione el archivo que descargó de Entorno de Pruebas y modificó, y cárguelo.

Configuración del Proyecto

Roles de seguridad: Debe ser Administrador del proyecto o Administrador de la aplicación.


12. Etiquetas de proyecto y nombres de campo

  • Ubicación: Consola de Administración > (Configuración del Proyecto) Etiquetas de proyecto y nombres de campo

  • Instrucciones: Localice en Entorno de Pruebas y en Production, y actualice los nombres de campo que haya personalizado y que desee reflejar en Production.

  • Tenga en cuenta que en esta sección no solo se actualizan las etiquetas del proyecto, sino que también se configuran aquí los controles de sus ajustes de Informe de estado, los ajustes de Impactos del proyecto y la página de Panel predeterminado global (Página de lista de seguimiento predeterminada), así que revíselos también.

  • Puede leer más aquí: Project Labels & Field Names.

13. Configurar características del proyecto

  • Ubicación: Consola de Administración > (Configuración del Proyecto) Configurar características del proyecto

  • Instrucciones: Alinee la configuración de Entorno de Pruebas con Production y haga clic en 'Guardar'.

14. Plantillas de proyectos

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > (Configuración del Proyecto) Plantillas de proyectos

Instrucciones:

Deberá hacer esto para cada plantilla de proyecto que desee migrar de Entorno de Pruebas a producción.

  1. Haga clic en el nombre de la plantilla o en el ícono de lápiz 'Editar' para abrir el cuadro de diálogo de detalles de la plantilla.

  2. Descargue los archivos de la plantilla.

Preparar el archivo

Cargar en Production

Instrucciones:

Deberá hacer esto para cada plantilla de proyecto que desee migrar de Entorno de Pruebas a producción.

  1. Haga clic en el botón 'Crear'.

  2. Agregue los detalles de la plantilla en el cuadro de diálogo, haciéndolos coincidir con la plantilla que está copiando desde Entorno de Pruebas.

  3. Haga clic en 'Guardar'.

  4. El cuadro de diálogo se cerrará.

  5. Busque la nueva plantilla en la lista y haga clic en el nombre o en el ícono de lápiz 'Editar'.

  6. Cargue los archivos de la plantilla que descargó de Entorno de Pruebas en las áreas correspondientes.

  7. Haga clic en 'Guardar'.

15. Impact, Probability and Risk Rating

  • Consola de Administración > (Configuración del Proyecto) Impact, Probability and Risk Rating

  • Instrucciones: Configure el impacto, la probabilidad y la calificación de riesgo en production para que coincidan con la configuración de su Entorno de Pruebas.

  • Puede leer más aquí: Impact, Probability & Risk Rating Configuration

16. Metodologías, Fases y Puertas de Decisión

Los proyectos utilizarán estos elementos, por lo que se recomienda migrar las metodologías, fases y puertas de decisión antes de cargar los proyectos si desea que el proyecto mantenga los vínculos con ellos.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > (Configuración del Proyecto) Metodologías, Fases y Puertas de Decisión

Nota: si las Stage Gates no están activadas, el enlace se mostrará como 'Methodologies, Phases, and Tasks'.

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Descargar'.

Preparar el archivo

  • No es necesario actualizar el archivo a menos que desee agregar o modificar las metodologías.

    Solo tenga en cuenta que si modifica alguna a la que estén vinculados sus proyectos, estas deberán actualizarse en el archivo de Detalles del proyecto.

  • Para obtener más orientación, consulte: Methodologies, Phases and Tasks Configuration y Stage Gates Configuration.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Edición Masiva'.

  3. Haga clic en 'Subir'.

  4. Elija el archivo que descargó de producción y cárguelo.

  5. Deberá crear manualmente las Phase Gates y Stage Gates en producción, ya que el archivo de edición masiva actualmente solo admite Methodologies, Phases y Phase Tasks.

  6. Haga clic en el botón 'Apply to All Projects' para aplicar las nuevas puertas a los proyectos existentes.


17. Tipos de proyectos

Los proyectos utilizarán estos elementos, por lo que se recomienda migrar los Tipos de proyectos antes de cargar los proyectos si desea que el proyecto mantenga los vínculos con ellos.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > (Configuración del Proyecto) Tipos de proyectos

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export MetaData'.

  3. El archivo se descargará automáticamente.

Preparar el archivo

  • No es necesario actualizar el archivo a menos que desee agregar o modificar los tipos de proyecto. Los ID se generarán automáticamente independientemente de si los deja o los elimina y los deja en blanco en el archivo.

    Solo tenga en cuenta que si modifica alguno al que estén vinculados sus proyectos, estos deberán actualizarse en el archivo de Detalles del proyecto.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Upload MetaData'.

  3. Haga clic en 'Subir'.

  4. Elija el archivo que descargó de producción y cárguelo.


18. Portfolios and SubPortfolios

Los proyectos utilizarán estos elementos, por lo que se recomienda migrar los portfolios y subportfolios antes de cargar los proyectos si desea que el proyecto mantenga los vínculos con ellos.

Requisitos previos: Si tiene administradores, aprobadores o visualizadores de portfolio o subportfolio asignados, entonces tiene sentido haber importado sus planes de recursos (que incluyen sus perfiles de recursos).

Si no lo ha hecho, puede volver y reasignar los administradores, aprobadores y visualizadores más adelante, una vez que haya creado los usuarios en el sistema.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > (Configuración del Proyecto) Portfolio and SubPortfolios

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export Portfolio & SubPortfolio'.

  3. El archivo se descargará automáticamente.

Preparar el archivo

  • No es necesario actualizar el archivo a menos que desee agregar o modificar los portfolios.

    Solo tenga en cuenta que si modifica alguno al que estén vinculados sus proyectos, estos deberán actualizarse en el archivo de Detalles del proyecto.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Upload Portfolio & SubPortfolio'.

  3. Haga clic en 'Subir'.

  4. Elija el archivo que descargó de producción y cárguelo.


19. Tier and Business Drivers

Los proyectos utilizarán estos elementos, por lo que se recomienda migrar los Tier and Business Drivers antes de cargar los proyectos si desea que el proyecto mantenga los vínculos con ellos.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Consola de Administración > (Configuración del Proyecto) Tier and Business Drivers

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Export Tier and Business Driver'.

  3. El archivo se descargará automáticamente.

Preparar el archivo

  • No es necesario actualizar el archivo a menos que desee agregar o modificar los tiers y business drivers.

    Solo tenga en cuenta que si modifica alguno al que estén vinculados sus proyectos, estos deberán actualizarse en el archivo de Detalles del proyecto.

Cargar en Production

Instrucciones:

  1. Haga clic en el menú 'Herramientas'.

  2. Seleccione 'Upload Tier and Business Driver'.

  3. Haga clic en 'Subir'.

  4. Elija el archivo que descargó de producción y cárguelo.

Proyectos

Roles de seguridad: Solo los usuarios con los roles de Administrador financiero y Administrador de datos en su cuenta pueden descargar y cargar los detalles del proyecto. Los usuarios que solo tienen el rol de Administrador financiero únicamente pueden descargar el archivo de detalles del proyecto, pero no pueden cargarlo.

20. Detalles del proyecto

Requisitos previos: Planes de recursos, Catalogs, Propiedades Personalizadas (Proyecto), Listas compartidas de propiedades personalizadas, Metadatos, Temas Globales, Etiquetas de proyecto y nombres de campo, Configurar características del proyecto, Metodologías, Fases y Puertas de Decisión, Tipos de proyectos, Portfolio and SubPortfolios, Tier and Business Drivers.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Administración de Datos > Detalles del proyecto (Descargar)

Instrucciones:
Haga clic en el botón 'Descargar' para 'Detalles del proyecto'; el archivo se descargará automáticamente.

O bien

Ubicación: Proyectos (navegación superior) > Herramientas > Edición Masiva

Instrucciones:

  1. Puede filtrar la lista de seguimiento de paneles para incluir solo el proyecto para el que desea descargar los datos.

    Por ejemplo, si desea migrar únicamente los proyectos 'Active', aplique el filtro de estado 'Active' antes de descargar el archivo de edición masiva de 'Detalles del proyecto'.

  2. 'Herramientas' > 'Edición Masiva'.

  3. Seleccione Detalles del proyecto en la parte izquierda del cuadro de diálogo de Edición Masiva.

  4. Si desea descargar los datos existentes de los proyectos en el archivo, establezca la marca en Yes. Para extraer un archivo de carga en blanco, establézcala en No.

  5. Haga clic en Descargar.

Preparar el archivo

  • Elimine del archivo de edición masiva cualquier fila de proyecto que no desee migrar.

  • Elimine todos los datos de las columnas que contienen ID y números de referencia de proyecto: ProjectID, ProjectGuid, Immediate Parent Id, Top Parent Project Id, Program Id.

  • Asegúrese de que sus campos de propiedad personalizada (los que comienzan con un guion bajo '_') estén disponibles en producción.

  • Puede dejar en el archivo los datos de Immediate Parent, Immediate Parent Ref, Top Parent Project, Top Parent Project Ref, Program, Program Ref, ReportingProgram y Reporting Program Ref para volver a vincular sus proyectos y crear las jerarquías de proyecto.

  • Puede dejar el dato de ProjectRef en el archivo. Las Tareas de cronograma hacen referencia a estos para vincularlas al proyecto.

  • Para obtener más orientación, consulte: Project Details: Bulk Edit y Project Details Upload

Cargar en Production

Ubicación: Administración de Datos > Detalles del proyecto (Cargar)

Instrucciones:

  1. Haga clic en el botón 'Cargar' para 'Detalles del proyecto'.

  2. Seleccione 'Cargar datos' y busque el archivo que descargó y modificó de Entorno de Pruebas.

O BIEN

Ubicación: Proyectos (navegación superior) > Herramientas > Edición Masiva

Instrucciones:

  1. 'Herramientas' > 'Edición Masiva'.

  2. Seleccione 'Detalles del proyecto' en la parte izquierda del cuadro de diálogo de Edición Masiva.

  3. Si desea descargar los datos existentes del proyecto/proyectos en el archivo, establezca la marca en Yes. Para extraer un archivo de carga en blanco, establézcala en No.

  4. Haga clic en Cargar.

  5. Seleccione el archivo que descargó y modificó de Entorno de Pruebas.

21. Schedules

Requisitos previos: Metadatos, proyectos (Detalles del proyecto) y Planes de recursos para vincular a los asignados de tareas.

Archivo: Schedule Tasks

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Proyectos (navegación superior) > Herramientas > Edición Masiva

Instrucciones:

  1. Puede filtrar la lista de seguimiento de paneles para incluir solo las tareas del proyecto para el que desea descargar los datos.

    Por ejemplo, si desea migrar únicamente los proyectos 'Active', aplique el filtro de estado 'Active' antes de descargar el archivo de edición masiva de 'Schedule Tasks' para obtener una lista de tareas solo de los proyectos activos.

  2. 'Herramientas' > 'Edición Masiva'.

  3. Seleccione 'Schedule Tasks' en la parte izquierda del cuadro de diálogo de Edición Masiva.

  4. Marque 'Incluir datos existentes' para descargar los datos existentes. Marque 'Include sub projects' para incluir subproyectos.

  5. Haga clic en Descargar.

Preparar el archivo

  • Elimine todos los datos de las columnas ProjectId, Id y Guid.

  • Importante: Recuerde que, cuando carga una fila de tarea de cronograma en un archivo de edición masiva que no tiene GUID, Fluid creará una nueva tarea con esos detalles. Si ya ha agregado alguna de las tareas de cronograma en Fluid, deberá eliminarlas del archivo para no crear tareas duplicadas en los proyectos.

  • Para obtener más información, consulte: Project Schedule Bulk Edit

Cargar en Production

Instrucciones:

  1. 'Herramientas' > 'Edición Masiva'.

  2. Seleccione 'Schedule Tasks' en la parte izquierda del cuadro de diálogo de Edición Masiva.

  3. Haga clic en Cargar.

  4. Seleccione el archivo que descargó y modificó de Entorno de Pruebas.

23. Impactos del proyecto

Requisitos previos: Etiquetas de proyecto y nombres de campo (Impactos del proyecto), proyectos (Detalles del proyecto) y Planes de recursos para mantener a los asignados de impactos.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Proyectos (navegación superior) > Herramientas > Edición Masiva

Instrucciones:

  1. Puede filtrar la lista de seguimiento de paneles para incluir solo los impactos del proyecto para el que desea descargar los datos.

    Por ejemplo, si desea migrar únicamente los proyectos 'Active', aplique el filtro de estado 'Active' antes de descargar el archivo de edición masiva de 'Impacts' para obtener una lista de impactos solo de los proyectos activos.

  2. 'Herramientas' > 'Edición Masiva'.

  3. Seleccione 'Impactos del proyecto' en la parte izquierda del cuadro de diálogo de Edición Masiva.

  4. Marque 'Incluir datos existentes' para descargar los datos existentes.

  5. Haga clic en Descargar.

Preparar el archivo

Cargar en Production

Instrucciones:

  1. 'Herramientas' > 'Edición Masiva'.

  2. Seleccione 'Impactos del proyecto' en la parte izquierda del cuadro de diálogo de Edición Masiva.

  3. Haga clic en Cargar.

  4. Seleccione el archivo que descargó y modificó de Entorno de Pruebas.

24. Informes de estado

Requisitos previos: Propiedades Personalizadas, Metadatos (RAG y Component RAG), proyectos (Detalles del proyecto), Planes de recursos, ya que los estados de proyecto utilizan asignados para establecer propietarios, e Impactos, para mantener los impactos vinculados.

Estas instrucciones le guían a través del proceso de importación del último informe de estado del proyecto para cada uno de los proyectos. Hay instrucciones para cargar informes de estado históricos por proyecto individual debajo de la primera tabla.

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Paneles de Proyecto (haga clic en el botón 'Proyectos' en la barra de navegación superior.

Instrucciones:

  1. Antes de descargar el archivo de edición masiva, puede agregar filtros al panel para seleccionar solo los proyectos que desea migrar.

    Por ejemplo, si solo desea migrar los proyectos activos, puede aplicar el filtro de estado 'Active' y descargar los detalles únicamente de esos proyectos.

  2. Haga clic en Herramientas > Edición Masiva.

  3. Seleccione 'Project Status' en la lista de la izquierda.

  4. Deje marcada la opción 'Include Existing Data'.

  5. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine todos los datos de las columnas ProjectId.

  • Elimine todos los datos de otras columnas que utilicen un ID, como las columnas Resource Issue/Risk Id, Scope Issue/Risk Id y Timeline Issue/Risk Id: tendrán ID diferentes en Production.

  • Elimine cualquier línea de proyectos para los que no desee cargar el estado en Production.

  • Para obtener más información, consulte: Project Status: Bulk Edit

Cargar en Production

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Seleccione 'Project Status' en la lista de la izquierda.

  3. Haga clic en 'Subir'.

  4. Cargue el archivo que descargó y actualizó de Entorno de Pruebas.

Para agregar los informes de estado históricos a un proyecto individual:

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Espacio de trabajo del proyecto

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Seleccione 'Project Status' en la lista de la izquierda.

  3. Deje marcada la opción 'Include Existing Data'.

  4. Haga clic en 'Descargar'.

Preparar el archivo

  • No es necesario actualizar el archivo, pero verifique que haya agregado a Production las propiedades personalizadas utilizadas por el informe de estado, o si no las va a migrar, elimine del archivo de edición masiva las columnas de propiedades personalizadas que no existan en Production.

  • Para obtener más información, consulte: Project Status: Bulk Edit

Cargar en Production

Instrucciones:

  1. Busque el proyecto correspondiente en Production al que desea aplicar los informes de estado.

  2. Haga clic en Herramientas > Edición Masiva.

  3. Seleccione 'Project Status'.

  4. Haga clic en 'Subir'.

  5. Cargue el archivo que descargó de Entorno de Pruebas'.

Pronósticos de recursos

25. Pronósticos de recursos

Requisitos previos: Gestión de Metadatos, Rate Cards, Etiquetas de recursos y nombres de campos, Planes de recursos, Detalles del proyecto.

Archivo: Pronósticos de recursos

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Paneles de Proyecto (haga clic en el botón 'Proyectos' en la barra de navegación superior.

Instrucciones:

  1. Antes de descargar el archivo de edición masiva, puede agregar filtros al panel para seleccionar solo los proyectos que desea migrar.

    Por ejemplo, si solo desea migrar los proyectos activos, puede aplicar el filtro de estado 'Active' y descargar los detalles únicamente de esos proyectos.

  2. Haga clic en Herramientas > Edición Masiva.

  3. Seleccione 'Resource Forecast' en la lista de la izquierda.

  4. Mantenga marcada la opción 'Incluir datos existentes'.

  5. Elija el rango de fechas que va a descargar.

  6. Haga clic en 'Descargar'.

Preparar el archivo

Cargar en Production

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Seleccione 'Resource Forecast' en la lista de la izquierda.

  3. Haga clic en 'Subir'.

  4. Seleccione y cargue el archivo que descargó y modificó de Entorno de Pruebas.


Finanzas del proyecto

Roles de seguridad: Debe ser Administrador financiero o Administrador de la aplicación.

26. Baseline Forecasts

Requisitos previos: Gestión de Metadatos, Detalles del proyecto, Monedas, Categorías y Tipos de gastos, Planes de recursos.

Archivo: Baseline Forecast

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Paneles de Proyecto (haga clic en el botón 'Proyectos' en la barra de navegación superior.

Instrucciones:

  1. Antes de descargar el archivo de edición masiva, puede agregar filtros al panel para seleccionar solo los proyectos que desea migrar.

    Por ejemplo, si solo desea migrar los proyectos activos, puede aplicar el filtro de estado 'Active' y descargar los detalles únicamente de esos proyectos.

  2. Haga clic en Herramientas > Edición Masiva.

  3. Seleccione 'Baseline Forecast' en la lista de la izquierda.

  4. Elija el rango de fechas que va a descargar.

  5. Elija 'Download Baseline Forecast' o 'Download Full Year Forecast', según lo que necesite.

  6. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine los datos de la columna ProjectId.

Cargar en Production

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Seleccione 'Baseline Forecast' en la lista de la izquierda.

  3. Haga clic en 'Subir'.

  4. Seleccione y cargue el archivo que descargó y modificó de Entorno de Pruebas.


27. Project Benefits

Requisitos previos: Gestión de Metadatos, Detalles del proyecto, Monedas, Categorías y Tipos de gastos, Planes de recursos.

Archivos: Project Benefits (Fluid Benefits-qualitative, Fluid Benefits-quantitative, Fluid Benefits-quantitativeNonResourcing)

Paso

Instrucciones

Descargar desde Entorno de Pruebas

Ubicación: Paneles de Proyecto (haga clic en el botón 'Proyectos' en la barra de navegación superior.

Instrucciones:

  1. Antes de descargar el archivo de edición masiva, puede agregar filtros al panel para seleccionar solo los proyectos que desea migrar.

    Por ejemplo, si solo desea migrar los proyectos activos, puede aplicar el filtro de estado 'Active' y descargar los detalles únicamente de esos proyectos.

  2. Haga clic en Herramientas > Edición Masiva.

  3. Seleccione 'Project Benefits' en la lista de la izquierda.

  4. Tiene tres opciones en forma de casillas de verificación: Download Qualitative Benefits, Download Quantitative Resourcing Benefits y Download Quantitative Non Resourcing Benefits. Si va a migrar todas estas, marque cada opción y descargue el archivo correspondiente por turno.

  5. Elija si desea 'Include closed benefits'.

  6. Haga clic en 'Descargar'.

Preparar el archivo

  • Elimine los datos de la columna ProjectId.

  • Elimine los datos de la columna GUID.

    Importante: Recuerde que, cuando carga una fila en un archivo de edición masiva que no tiene GUID, Fluid creará un nuevo beneficio de proyecto con esos detalles. Si ya ha agregado alguno de los beneficios de proyecto en Fluid, elimínelos del archivo para no duplicar los beneficios de proyecto.

  • Para obtener más información, consulte: Project Benefits: Bulk Edit

Cargar en Production

Instrucciones:

  1. Haga clic en Herramientas > Edición Masiva.

  2. Seleccione 'Project Benefits' en la lista de la izquierda.

  3. Haga clic en 'Subir'.

  4. Seleccione y cargue el archivo que descargó y modificó de Entorno de Pruebas. Haga esto para cada uno de los archivos que descargó.

Paneles de proyecto y plantillas de informes



Solución de problemas

Archivo masivo: filas omitidas o datos no cargados

Cuando se cargue su archivo, el cuadro de diálogo mostrará cualquier problema encontrado. Mostrará el número de fila de la hoja de cálculo y el motivo por el que se omitió la fila. Puede usar esta información para diagnosticar cualquier problema con sus datos.


Para corregir cualquier problema con los datos de las filas omitidas, en la mayoría de los casos puede volver a abrir el archivo que cargó, realizar las actualizaciones necesarias, guardarlo y volver a cargarlo.

Nota importante: Si las filas del archivo usan GUIDs, recuerde no volver a cargar el archivo con las líneas que ya se cargaron correctamente, o podría crear duplicados de esos elementos. El archivo 'Schedule Tasks' es un ejemplo de esto.

En los casos en que algunas filas no se hayan cargado y las filas usen GUIDs, debe eliminar del archivo cualquier línea que haya confirmado que sí se cargó, para no volver a crear esos elementos.

Was this article helpful?